> ## Documentation Index
> Fetch the complete documentation index at: https://docs.leen.dev/llms.txt
> Use this file to discover all available pages before exploring further.

# IDP Integrations

> Information about the Identity Provider integrations available in Leen. Find out which fields are supported by each integration and how to configure them.

## Supported User Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `id` | ✅ | ✅ | |
| `domain` | ✅ | ✅ | |
| `email_addr` | ✅ | ✅ | |
| `full_name` | ✅ | ✅ | |
| `name` | ✅ | ✅ | |
| `vendor_id` | ✅ | ✅ | |
| `vendor_status` | ✅ | | |
| `vendor_created_at` | ✅ | ✅ | |
| `activated_at` | ✅ | ✅ | |
| `last_status_changed_at` | ✅ | | |
| `last_login_at` | ✅ | ✅ | |
| `last_updated_at` | ✅ | | |
| `last_password_changed_at` | ✅ | ✅ | |
| `is_mfa_enabled` | ✅ | ✅ | |
| `is_admin` | ✅ | ✅ | |

## Supported Group Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `id` | ✅ | ✅ | |
| `types` | ✅ | ✅ | |
| `description` | ✅ | ✅ | |
| `name` | ✅ | ✅ | |
| `vendor_id` | ✅ | ✅ | |
| `vendor_created_at` | ✅ | ✅ | |
| `last_membership_updated_at` | ✅ | | |
| `last_updated_at` | ✅ | | |

## Supported Application Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `id` | ✅ | ✅ | |
| `labels` | ✅ | ✅ | |
| `name` | ✅ | ✅ | |
| `vendor_id` | ✅ | ✅ | |
| `version` | ✅ | | |
| `vendor_status` | ✅ | | |
| `vendor_created_at` | ✅ | ✅ | |
| `last_updated_at` | ✅ | | |

## Supported User-App Association Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `user_app_last_login_at` | ✅ | ✅ | |

## Supported IDP Alert Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `id` | ✅ | ✅ | ✅ |
| `activity_id` | ✅ | ✅ | ✅ |
| `activity_name` | ✅ | ✅ | ✅ |
| `category_name` | ✅ | ✅ | ✅ |
| `category_uid` | ✅ | ✅ | ✅ |
| `class_name` | ✅ | ✅ | ✅ |
| `class_uid` | ✅ | ✅ | ✅ |
| `enrichments` | ✅ | | |
| `evidences` | ✅ | ✅ | |
| `finding_info` | ✅ | ✅ | ✅ |
| `metadata` | ✅ | ✅ | ✅ |
| `message` | ✅ | | |
| `severity` | ✅ | ✅ | ✅ |
| `severity_id` | ✅ | ✅ | ✅ |
| `type_uid` | ✅ | ✅ | ✅ |
| `type_name` | ✅ | ✅ | ✅ |
| `time` | ✅ | ✅ | ✅ |
| `resources` | | ✅ | ✅ |

## Supported Policy Fields

| Leen Model | Okta IDP | MS Entra IDP | AWS Access Analyzer |
| - | - | - | - |
| `id` | ✅ | ✅ | |
| `name` | ✅ | ✅ | |
| `description` | ✅ | ✅ | |
| `type` | ✅ | ✅ | |
| `status` | ✅ | ✅ | |
| `priority` | ✅ | ✅ | |
| `vendor_id` | ✅ | ✅ | |
| `vendor_created_at` | ✅ | ✅ | |
| `last_updated_at` | ✅ | ✅ | |
| `configuration` | ✅ | ✅ | |
| `is_deleted` | ✅ | ✅ | |


This documentation is built and hosted on [Mintlify](https://mintlify.com), a developer documentation platform.